You are here

Cannot login on Xubuntu :(

Before posting make sure you are aquainted with our forum rules.

20 posts / 0 new
Last post
Offline
Cannot login on Xubuntu :(

Hi guys, I need some help :( with the following problem:

Since I moved to my new appartement, I haven't been able to login on curvefever.com/play2.php. Here is a more detailed description of what's happening:

When I type in my name and password and press login, it just says "Signing in" and it doesn't proceeed further. I tried other accounts or login as guest, but it doesn't help. I was searching through the cf forum and tried the suggestions that I found, but again it was not successful. Namely I
-tried other browsers (normally I use Firefox), i.e. Chromium, Chrome and also the standalone version
-changed the preferred and secondary DNS servers as Geert suggests in http://curvefever.com/content/when-game-says-servers-unreachable

However, I noticed this important thing:
I have Xubuntu 14.04 and when I use my computer at some other places (i.e. with different wifi networks), it works correctly (I can login to cf). So then I tried another computer which is kinda newer and has Ubuntu, but it also has the same problem with logging to cf on my home network :( But the key thing is that when I tried it on a computer with Windows, it worked! Unfortunately, on my own computer I only have Xubuntu and so I need to get it running in there. And since I have already tried everything that came to my mind, I would like to ask you if you have any advice.

Best,

spaceworm

P.S. Other (minor, but perhaps useful) observations:
-when I reload the webpage (while it says "Signing in") it says that I am already signed in, which means that at least my previous request for login gets to the cf server.
-when I press F12, then under the tab "Console" it says "TypeError: document.flashachtung.focus is not a function" (play2.php:34:7)

Tranquility. †'s picture
Offline
Clan: Blub

I had a quick Google and I seen Ubuntu have had problems with Flash Player in the past with conflicting versions (or something like that anyway). Maybe you could try a clean uninstall of Flash Player and then re-install it.

I'm afraid I can't really offer any help other than that wild guess though :( Another possibility (from your description) could be some sort of conflict between your firewall and ubuntu. 

Offline

OK, I will try it, thanks :)

However, I am currently away for a few days, so I cannot see if it solves the problem. When I return, I will look at it ASAP.

Best,

spaceworm

Tranquility. †'s picture
Offline
Clan: Blub

Good luck :)

Offline

Hi there,

I have tried all the things suggested above and the problem still persists...

Does someone have a suggestion? I repeat: I cannot login (it just keeps saying "signing in") - apparently it is some problem between Ubuntu and my connection. I already checked flash, firewall, etc.

Here is the screenshot of the network requests after pressing the Guest Login button - it appears to stop before reaching the page api.playerio.com/api/24.

http://mab.to/R65Q3wPGm

Does that signify anything reasonable?

I appreciate any possible help, I am really desperate and I have already passed many hours during the last month for trying to solve it on my own... :(

spaceworm

zeroZshadow's picture
Offline

Hmm there should be more requests after that.

Are those all the requests it does after you start it?

zeroZshadow's profile on curvefever

Offline

Yes :( that is all (when I login as guest)
 

zeroZshadow's picture
Offline

Sorry but I really have no idea on how to help you with this. When I run it on my ubuntu installation, things work just fine, and I dont have a clue what could have it do this without giving any errors.

zeroZshadow's profile on curvefever

Offline

:(

Well, at least the F12 console says (during the "signing in" process)

"TypeError: document.flashachtung.focus is not a function" (play2.php:34:7)

zeroZshadow's picture
Offline

Actually, thats what would be crashing it. Let me have a look at this this week.

zeroZshadow's profile on curvefever

Offline

Also, I can say that it works without problem on other wifi networks, so I guess it's a problem with some compatibility between (X)Ubuntu and my network.

It's not the problem of this network itself, since the login works fine on Windows...unfortunately, on my own computer I have (X)Ubuntu... :( :(

I really tried everything that I found either on this forum or on some other fora for games using similar machinery...

At this point I would appreciate any ideas, since I am pretty desperate :( and I really need to get it working...

Offline

Thanks many times!!! :)

Offline

Hm...on other wifi network, where I can connect, it still says

"TypeError: document.flashachtung.focus is not a function" (play2.php:34:7),

so I don't know if that is really the problem...

zeroZshadow's picture
Offline

Wait wait wait,

So on the same pc, but a different wifi network, the game does work?

zeroZshadow's profile on curvefever

Offline

Yes

zeroZshadow's picture
Offline

Then the issue lies with the wifi (router) you are connected to, not curvefever or anything on your pc.

zeroZshadow's profile on curvefever

Offline

Yes, I agree, but cf still works on windows (on this wifi network)...

So there must be something specific for the pair (X)Ubuntu <-> my wifi network

I just cant figure out what it is...

Offline

OK, now I changed my system to WIndows 7, but it still doesn't work :(

I don't get it - on Windows 10 it works, but on my Ubuntu, Xubuntu and Win7 it doesn't ...

Tranquility. †'s picture
Offline
Clan: Blub

The issue still looks to be in the router itself though. You said this happened on multiple computers all over the same router. I assume you've tried resetting it...? Perhaps consider resetting to factory settings too but I can't be certain that will solve anything.

I would perhaps try asking on your ISP forums. Maybe someone has a common issue on something other than CF.

Offline

OK, thanks for suggestions :)